HTTPS is now enabled (it will break some offsite images)

Discuss technical problems and features here
User avatar
tiia
Green Belt
Posts: 468
Joined: Tue Mar 15, 2016 11:52 pm
Location: Finland
Languages: German (N), English (?), Finnish (~B2), Spanish (B1), Swedish (A1?)
Language Log: viewtopic.php?t=2374
x 709

Re: HTTPS is now enabled (it will break some offsite images)

Postby tiia » Sat Apr 21, 2018 9:53 pm

Hey,
I got the message, that the https certificate of the forum expired this evening. Could you please fix it? Thank you. :)

(Btw. the old super challenge site seems to have the same problem for quite a while now: https://super-challenge.language-learners.org/ )
1 x
Corrections for entries written in Finnish, Spanish or Swedish are welcome.
Project 30before30: 22 / 30

User avatar
eido
Blue Belt
Posts: 882
Joined: Tue Jan 30, 2018 8:31 pm
Languages: EN (N), ES (B2), others
x 1404

Re: HTTPS is now enabled (it will break some offsite images)

Postby eido » Sat Apr 21, 2018 11:52 pm

Good old Internet Explorer is allowing me to get on the site even with the certificate error, but I imagine anyone who relies solely on any other browser isn't able to use the site. If they'd even be as daring as me to use it with the issue.
1 x
"He's satisfied with himself. If you have a soul you can't be satisfied."
- Graham Greene (given to me by @reineke)

User avatar
Teango
Blue Belt
Posts: 500
Joined: Mon Jul 06, 2015 4:55 am
Location: Honolulu, Hawaiʻi
Languages: (* current focus)
native: en
advanced: de
intermediate: es, fr, haw, nzs, ru*
beginner: egy, ga, hwc, ja, la, sv
–: fa, zu
Language Log: https://teango.wordpress.com/
x 1460
Contact:

Re: HTTPS is now enabled (it will break some offsite images)

Postby Teango » Sun Apr 22, 2018 12:21 am

I'm getting similar web server security certificate expiration warnings on all browsers, but was able to bypass the error page and access our site by adding a temporary security exception for LLorg on Firefox.
1 x
365 Day Challenge: 121 / 365

Arnaud
Blue Belt
Posts: 875
Joined: Sat Jul 18, 2015 11:57 am
Location: France
Languages: French (N), Russian (int)
Language Log: viewtopic.php?t=1524
x 1871

Re: HTTPS is now enabled (it will break some offsite images)

Postby Arnaud » Sun Apr 22, 2018 5:32 am

Teango wrote:I'm getting similar web server security certificate expiration warnings on all browsers, but was able to bypass the error page and access our site by adding a temporary security exception for LLorg on Firefox.

Same thing. Please update. I've reported my own message so that moderators should be notified by email...
0 x

User avatar
coldrainwater
Green Belt
Posts: 389
Joined: Sun Jan 01, 2017 4:53 am
Location: Houston, Texas
Languages: EN (N), ES (intermediate), DE (beginner)
Language Log: https://forum.language-learners.org/vie ... =15&t=7636
x 661

Re: HTTPS is now enabled (it will break some offsite images)

Postby coldrainwater » Sun Apr 22, 2018 6:57 am

Same story with Chrome. I added a security exception, cleared all data (cookies, browsing data etc), restarted chrome, then the option to ''access the site anyway'' was available.
1 x

User avatar
Serpent
Black Belt - 3rd Dan
Posts: 3301
Joined: Sat Jul 18, 2015 10:54 am
Location: Moskova
Languages: heritage
Russian (native); Belarusian, Polish

fluent or close: Finnish+ (certified C1), English; Portuguese, Spanish, German+, Italian+
learning: Croatian+, Ukrainian, Czech; Romanian+, Galician; Danish, Swedish
exploring: Latin, Karelian, Catalan, Dutch, Chaucer's English
+ means exploring the dialects/variants
x 4389
Contact:

Re: HTTPS is now enabled (it will break some offsite images)

Postby Serpent » Sun Apr 22, 2018 7:54 am

Yeah several people have reported the problem on facebook too :(
0 x
LyricsTraining now has Finnish and Polish :)
Corrections welcome

User avatar
emk
Brown Belt
Posts: 1391
Joined: Sat Jul 18, 2015 12:07 pm
Location: Vermont, USA
Languages: English (N), French (B2+)
Badly neglected "just for fun" languages: Middle Egyptian, Spanish.
Language Log: viewtopic.php?f=15&t=723
x 4679
Contact:

Re: HTTPS is now enabled (it will break some offsite images)

Postby emk » Mon Apr 23, 2018 12:37 pm

Fixed. The Let's Encrypt process—which has the one job of automatically renewing the security certificate every month or two—was out to lunch. I rebooted the box and it was fixed.

My apologies for the downtime! I had just gotten back from vacation and was stripping a bunch of old cabinets outside, in the first nice weather we've had in a while. Rdearman had contacted me, but GMail had put his email in a folder marked "Peu importants". Um, no thanks, GMail.

My apologies for not having noticed this faster. We take our uptime seriously here!

(And now I need to perform my periodic ritual of learning a whole new specialized French vocabulary, this time for woodworking, painting and building maintenance. Language learning never ends!)
36 x

User avatar
Serpent
Black Belt - 3rd Dan
Posts: 3301
Joined: Sat Jul 18, 2015 10:54 am
Location: Moskova
Languages: heritage
Russian (native); Belarusian, Polish

fluent or close: Finnish+ (certified C1), English; Portuguese, Spanish, German+, Italian+
learning: Croatian+, Ukrainian, Czech; Romanian+, Galician; Danish, Swedish
exploring: Latin, Karelian, Catalan, Dutch, Chaucer's English
+ means exploring the dialects/variants
x 4389
Contact:

Re: HTTPS is now enabled (it will break some offsite images)

Postby Serpent » Sun Oct 28, 2018 6:13 pm

emk wrote:The site is mostly back online. However, for now, you must connect using "https:" and not "http:". I'll work on setting up a redirect.
has this been fixed? I've tried typing http and it does seem to redirect to https now :)
(Of course I have it bookmarked as https :))

Also, just noticed that the main page still links to http :?
0 x
LyricsTraining now has Finnish and Polish :)
Corrections welcome

User avatar
emk
Brown Belt
Posts: 1391
Joined: Sat Jul 18, 2015 12:07 pm
Location: Vermont, USA
Languages: English (N), French (B2+)
Badly neglected "just for fun" languages: Middle Egyptian, Spanish.
Language Log: viewtopic.php?f=15&t=723
x 4679
Contact:

Re: HTTPS is now enabled (it will break some offsite images)

Postby emk » Sun Oct 28, 2018 8:27 pm

Serpent wrote:
emk wrote:The site is mostly back online. However, for now, you must connect using "https:" and not "http:". I'll work on setting up a redirect.
has this been fixed? I've tried typing http and it does seem to redirect to https now :)

I just fixed the HTTP to HTTPS redirection.

The old system actually had a built-in rule that told your browser to always use HTTPS, even if you typed HTTP. This is an important security feature. So most users would redirect automatically before even talking to the server. The new system doesn't have this (yet, at least), and we would probably need to add something like this on the server side.
1 x


Return to “Technical Support and Feature Requests”

Who is online

Users browsing this forum: No registered users and 2 guests