Bug in Postlove extension

Discuss technical problems and features here
User avatar
smallwhite
Black Belt - 1st Dan
Posts: 1951
Joined: Mon Jul 06, 2015 6:55 am
Languages: Native: Cantonese;
Good: English, French, Spanish, Italian;
Mediocre: Mandarin, German, Swedish, Dutch;
Some: Greek;
Studying: Turkish, Portuguese (6wc).
.
x 3399
Contact:

Bug in Postlove extension

Postby smallwhite » Wed Oct 05, 2016 12:16 pm

So I was wondering if s_allard ever likes anyone's posts, I mean if he ever clicks "like" / the heart, so I went to his profile and clicked:
Likes ... Show list with all like actions

and looked at the results, and noticed that from page 2 onwards, the URLs to each thread is incorrect. For example, for the thread titled "Breakthroughs...",

the URL is shown as this:
http://forum.language-learners.org/app.php/postlove/210/viewtopic.php?t=2961

causing this error message:
No route found for "GET /postlove/210/viewtopic.php"

because the correct URL should be this:
http://forum.language-learners.org/viewtopic.php?t=2961

Thanks.
Last edited by smallwhite on Wed Oct 05, 2016 1:42 pm, edited 1 time in total.
0 x
Dialang or it didn't happen.

The real LLorg

User avatar
rdearman
Site Admin
Posts: 3875
Joined: Thu May 14, 2015 4:18 pm
Location: United Kingdom
Languages: English (N)
Language Log: viewtopic.php?f=15&t=1836
x 8546
Contact:

Re: Bug in postlove feature

Postby rdearman » Wed Oct 05, 2016 1:03 pm

smallwhite wrote:So I was wondering if s_allard ever likes anyone's posts, I mean if he ever clicks "like" / the heart, so I went to his profile and clicked:
Likes ... Show list with all like actions

and looked at the results, and noticed that from page 2 onwards, the URLs to each thread is incorrect. For example, for the thread titled "Breakthroughs...",

the URL is shown as this:
app.php/postlove/210/viewtopic.php?t=2961

causing this error message:
No route found for "GET /postlove/210/viewtopic.php"

because the correct URL should be this:
viewtopic.php?t=2961

Thanks.


I opened a bug report on the PostLove extension area on Github. https://github.com/satanasov/postlove/issues/33
2 x
: 4 / 100 100 Italian paperbacks:

User avatar
smallwhite
Black Belt - 1st Dan
Posts: 1951
Joined: Mon Jul 06, 2015 6:55 am
Languages: Native: Cantonese;
Good: English, French, Spanish, Italian;
Mediocre: Mandarin, German, Swedish, Dutch;
Some: Greek;
Studying: Turkish, Portuguese (6wc).
.
x 3399
Contact:

Re: Bug in postlove feature

Postby smallwhite » Mon Nov 27, 2017 11:54 am

rdearman wrote:I opened a bug report on the PostLove extension area on Github. https://github.com/satanasov/postlove/issues/33


I'd like to follow up on this because the bug is still there. But I saw you say on Github "Works now" and closed your bug report. But you probably weren't aware / forgot / doing something different from me:

smallwhite wrote:So I was wondering if s_allard ever likes anyone's posts, I mean if he ever clicks "like" / the heart, so I went to his profile and clicked:
Likes ... Show list with all like actions

and looked at the results, and noticed that from page 2 onwards, the URLs to each thread is incorrect. For example, for the thread titled "Breakthroughs...",

the URL is shown as this:
app.php/postlove/210/viewtopic.php?t=2961

causing this error message:
No route found for "GET /postlove/210/viewtopic.php"

because the correct URL should be this:
viewtopic.php?t=2961

Thanks.


The bug only appears on page 2 onwards and not on the first page of the results. I'm looking at the results now and it seems that the presentation has changed a bit since. When the results are shown (initially) as a pop-up that covers most of the page with the remainder of the webpage barely showing through a semi-transparent black background, the links work fine. Then when you click to see other pages, the results are shown as a normal LLorg page, and here, the links are bad. That is, not work when trying to see older results.
1 x
Dialang or it didn't happen.

The real LLorg

User avatar
Iversen
Black Belt - 1st Dan
Posts: 1898
Joined: Sun Jul 19, 2015 7:36 pm
Location: Denmark
Languages: Monolingual travels in Danish, English, German, Dutch, Swedish, French, Portuguese, Spanish, Catalan, Italian, Romanian and (part time) Esperanto
Ahem, not yet: Norwegian, Afrikaans, Platt, Scots, Russian, Serbian, Bulgarian, Albanian, Greek, Latin, Irish, Indonesian and a few more...
Language Log: viewtopic.php?f=15&t=1027
x 3832

Re: Bug in Postlove extension

Postby Iversen » Thu Nov 30, 2017 11:45 pm

I have seen something similar in html in links where "http://" or "https://" was missing.
0 x


Return to “Technical Support and Feature Requests”

Who is online

Users browsing this forum: No registered users and 2 guests